Photoshop Weather Effects – Snow
Written by Steve Patterson. In this photo effects tutorials, we’ll learn how to add falling snow to your outdoor
winter photos using Photoshop CS6 and CC (Creative Cloud). If you’re using an earlier version of Photoshop,
don’t worry, we didn’t leave you out in the cold. Simply follow along with our original Photoshop Snow
Effect tutorial!
In previous tutorials, we learned how to create a starry night sky effect and also how to make it rain in an
image, and you may be thinking, “That’s great, but what does that have to do with creating snow?”. Well, if
you followed along with those other tutorials, you may have noticed that the same basic technique for adding
stars in the sky was also used to create the rain effect. And as you work through this tutorial, you’ll spot the
same technique being used again to create the snow! One basic technique, three completely different
possibilities!
That’s why it’s always better to learn how and why Photoshop works rather than just blindly following steps,
and why I always try to explain each step as best I can. The more you understand Photoshop and the more you
focus on learning tools and techniques rather than memorizing steps, the more you’ll begin to see the world the
way Photoshop sees it (scary but true). And one day, an amazing idea will pop into your head and you’ll
realize, "I think I know how to create that in Photoshop!". Life from that moment on will never be the same.
Having said that, let’s learn how to make it snow. Here’s the image I’ll be starting with (girl in winter forest
photofrom Shutterstock):

The original photo.

And here’s what it will look after adding adding the snow:

The final result.

Let’s get started!

Step 1: Add A New Blank Layer
With our photo newly opened in Photoshop, if we look in the Layers panel, we see the image sitting all by
itself on the Background layer. We want to keep the snow effect separate from the original image, so let’s
start by adding a new blank layer for the effect. Press and hold the Alt (Win) / Option (Mac) key on your
keyboard and click theNew Layer icon at the bottom of the Layers panel:

Clicking the New Layer icon while holding Alt (Win) / Option (Mac).

Holding Alt (Win) / Option (Mac) while clicking the New Layer icon tells Photoshop to first pop open
the New Layer dialog box before adding the layer, giving us a chance to name it before it’s added. Name the
layer “Snow”, then click OK to close out of the dialog box. Don’t worry about any of the other options:

Naming the layer in the New Layer dialog box.

Photoshop adds our new Snow layer above the Background layer. The checkerboard pattern in the
layer’spreview thumbnail to the left of its name is Photoshop’s way of telling us the layer is currently blank:

The Layers panel showing the new Snow layer.

Step 2: Fill The New Layer With Black
Next, we’ll use Photoshop’s Fill command to fill our new layer with black (even though snow should be white,
but we’ll get to that in a bit). Go up to the Edit menu in the Menu Bar along the top of the screen and
choose Fill:

Going to Edit > Fill.

This opens the Fill dialog box. Set the Use option at the top to Black. In the Blending section in the bottom of
the dialog box, make sure Mode is set to Normal and Opacity is at 100%. Click OK when you’re done to
close out of the dialog box:

The Fill options.

Photoshop fills the Snow layer with black, and because this layer is sitting above the Background layer, it
temporarily hides our photo from view:

Filling the Snow layer with black hides the photo in the document.

Step 3: Apply The Add Noise Filter
Let’s use Photoshop’s Add Noise filter to add a bunch of random white dots to our black-filled layer. These
white dots will eventually become our falling snow. Go up to the Filter menu at the top of the screen,
choose Noise, then choose Add Noise:

Going to Filter > Noise > Add Noise.

This opens the Add Noise dialog box. Drag the Amount slider a little to the right to set the value to 25% (or
just enter "25" directly into the box). In the Distribution section in the bottom of the dialog box,
select Gaussian, then select Monochromatic at the very bottom. This will prevent any colors other than black
and white from being mixed in with the noise. Click OK when you’re done to close out of the dialog box:

The Add Noise filter options.

Photoshop fills the Snow layer with a whole bunch of little white dots (or as Photoshop calls it, “noise”).
They’ll appear rather faint for now, but we’ll brighten them later:

The image after applying the Add Noise filter to the Snow layer.

Step 5: Change The Layer Blend Mode To Screen
Another problem with the noise is that it’s completely blocking our original photo from view. To fix that,
change theblend mode of the Snow layer from Normal (the default setting) to Screen:

Changing the Snow layer’s blend mode to Screen.

The Screen blend mode hides all the areas of black on the layer, leaving only the white noise visible and
making it look more like snow:

Changing the Snow layer’s blend mode to Screen lets us see the original photo through the noise.

Step 6: Apply The Motion Blur Filter
If we want our snow to look like it’s actually falling and not just frozen in time, we’ll need to add a bit of
motion to it. For that, we’ll use Photoshop’s Motion Blur filter. Go up to the Filter menu, choose Blur, then
choose Motion Blur:

Going to Filter > Blur > Motion Blur.

This opens the Motion Blur dialog box. First, set the angle you want your snow to be falling from using
the Angleoption, either by entering a value directly into the box or by turning the wheel to the right of the box.
I’m going to set my angle to -65° so the snow will appear to be falling from the top left. We then control how
much motion blur is added using the Distance value. All we need is a hint of motion, not too much (otherwise
it will look more like rainthan snow), so set your Distance value to somewhere between 8 to 12
pixels depending on the size of your image:

The Motion Blur options.

Click OK when you’re done to close out of the dialog box. Here’s my effect after applying the Motion Blur
filter (I’ve zoomed in just to make the result a bit easier to see):

The snow now looks more like it’s falling.

Step 7: Add A Levels Adjustment Layer
Next, we’ll reduce the amount of snow and also brighten it up at the same time using a Levels adjustment
layer. Once again press and hold the Alt (Win) / Option (Mac) key on your keyboard and this time, click
the New Adjustment Layer icon at the bottom of the Layers panel:

Clicking the New Adjustment Layer icon while holding Alt (Win) / Option (Mac).

Choose Levels from the list of adjustment layers that appears:

Choosing a Levels adjustment layer.

Photoshop will again pop open the New Layer dialog box. Select the Use Previous Layer to Create
Clipping Mask option by clicking inside its checkbox. This will clip the adjustment layer to the Snow layer
directly below it so that anything we do with the adjustment layer will affect only the Snow layer. It will have
no effect on the image on the Background layer. Click OK when you’re done to close out of the dialog box:

Selecting the Use Previous Layer to Create Clipping Mask option.

The Layers panel now shows our new Levels adjustment layer (Levels 1) directly above the Snow layer. It
appears indented to the right with a small arrow pointing down at the Snow layer, which is Photoshop’s way of
telling us that the adjustment layer is clipped to the layer below:

The Layers panel showing the Levels adjustment layer.

Learn the essentials of using Clipping Masks in Photoshop

Step 8: Drag The Black Point And White Point Sliders

The various options and controls for the Levels adjustment layer appear in Photoshop’s Properties panel. In
the center of the panel is the histogram, a graph showing us the current tonal range of the image (or in this
case, of the Snow layer). If you look directly below the histogram, you’ll find three small sliders. The black
point slider is on the far left, and the white point slider is on the far right. There’s also a gray slider in the
middle but for our purposes here, we don’t need it. All we need are the black point and white point sliders:

The black point (left) and white point (right) sliders below the histogram.

To reduce the amount of snow, click on the black point slider and begin slowly dragging it towards the right.
Keep an eye on your image as you drag and you’ll see the darker areas of snow (meaning the areas that were
more gray than white) becoming even darker, eventually disappearing completely. Then, to brighten up the
remaining snow, as well as increase its overall contrast, click on the white point slider and begin slowly
dragging it towards the left. The further you drag, the brighter the snow becomes. You can go back and forth
with the two sliders to fine-tune the results to your liking:

Dragging the black point and white point sliders.

Here’s my effect after dragging the sliders:

The effect after reducing and brightening the snow.

Step 9: Duplicate The Snow Layer And Adjustment Layer
Let’s add some depth to the effect by creating a second layer of snow, this time with bigger snowflakes (so
they’ll look like they were closer to the camera). To do that, we’ll need to make a copy of both our Snow layer
and the Levels adjustment layer above it. The adjustment layer is already selected in the Layers panel (it’s
highlighted in blue), so hold down the Shift key on your keyboard and click on the Snow layer. This will select
both layers at once:

Holding Shift and clicking the Snow layer to select both layers.

With both layers selected, go up to the Layer menu at the top of the screen, choose New, then choose Layer
via Copy. Or, you can access the same command from the keyboard by pressing Ctrl+J (Win)
/ Command+J (Mac). Either way works:

Going to Layer > New > Layer via Copy.

A copy of both layers appears above the originals (the copies have the word “copy” in their name):

Both the Snow and Levels adjustment layers have been duplicated.

Step 10: Select The Snow Copy Layer
Click on the Snow copy layer in the Layers panel to select it. This will also deselect the adjustment layer above
it:

Selecting the Snow copy layer.

Step 11: Rotate The Layer 180°

Let’s rotate the layer so that these new snowflakes are not just sitting on top of the originals. Go up to
the Editmenu, choose Transform, then choose Rotate 180°:

Going to Edit > Transform > Rotate 180°.

With the layer rotated 180°, the copied snowflakes are still falling at the same angle as the originals but they’re
now spaced out differently, giving us twice as much snow as we had before:

The effect after rotating the layer.

Step 12: Apply The Crystallize Filter
We need to make these new snowflakes bigger than the originals. We could just scale the layer again, but let’s
try something different. We’ll use Photoshop’s Crystallize filter. Go up to the Filter menu, choose Pixelate,
then choose Crystallize:

Going to Filter > Pixelate > Crystallize.

This opens the Crystallize dialog box. The Crystallize filter breaks an image into little sections, or “cells”, of
color, and we adjust the size of the cells with the Cell Size option at the bottom of the dialog box. A value
of 10 to 12usually works well for this effect. Since my image is fairly large, I’ll go with the higher value of 12:

Setting the Cell Size value in the Crystallize dialog box.

Click OK when you’re done to close out of the dialog box. You may need to give Photoshop some time to
complete the effect, but when it’s done, the new snowflakes will appear larger than the originals. We’ll still
need to add some motion to them again, which is what we’ll do next:

The effect after applying the Crystallize filter.

Step 13: Apply The Motion Blur Filter
Go back up to the Filter menu, choose Blur, then choose Motion Blur:

Going back to Filter > Blur > Motion Blur.

Photoshop once again opens the Motion Blur dialog box. Leave the Angle value set to whatever you set it to
last time (in my case, -65°) but since these new snowflakes are a bit larger than the originals, increase
the Distancevalue to somewhere between 16 to 20 pixels, again depending on the size of your image. Click
OK when you’re done:

Using a slightly larger Distance value this time.

Step 14: Re-Adjust The Levels Sliders
Finally, click on the Levels adjustment layer (Levels 1 copy) above the Snow copy layer to select it:

Selecting the copy of the Levels adjustment layer.

The Levels controls re-appear in the Properties panel. Drag the black point and white point sliders left or right
to make any needed adjustments to the appearance of the snow, reducing the amount of snow with the black
point slider and increasing its brightness with the white point slider. This time, we’re affecting only the larger
flakes on theSnow copy layer. The original snowflakes (on the original Snow layer) are not affected:

Only the Snow copy layer is affected this time by the sliders.

And with that, we’re done! Here, after using the sliders to fine-tune the appearance of the larger flakes, is my
final snow effect:

The final effect.

